Complete.Org: Mailing Lists: Archives: freeciv-dev: July 2004:
[Freeciv-Dev] Re: (PR#8754) effects patch
Home

[Freeciv-Dev] Re: (PR#8754) effects patch

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: undisclosed-recipients: ;
Subject: [Freeciv-Dev] Re: (PR#8754) effects patch
From: "Vasco Alexandre da Silva Costa" <vasc@xxxxxxxxxxxxxx>
Date: Wed, 7 Jul 2004 11:22:13 -0700
Reply-to: rt@xxxxxxxxxxx

<URL: http://rt.freeciv.org/Ticket/Display.html?id=8754 >

On Wed, 7 Jul 2004, Jason Short wrote:

> <URL: http://rt.freeciv.org/Ticket/Display.html?id=8754 >
>
> Per Inge Mathisen wrote:
>
> > I think we should remove:
>
> > EFT_FOOD_PER_TILE
> > EFT_TRADE_PER_TILE
>
> We have (and need) EFT_PROD_PER_TILE, we should have the other two as
> well...
>
> However I'd be in favor of eventually replacing these with a single
> EFT_OUTPUT_PER_TILE, with a parameter that tells which output
> (food/prod/trade/lux/sci/gold).  A similar change would allow the
> removal of a number of other effects.

That would make the checks slower and I really don't see an advantage to
it. You would use:

get_city_output_bonus(pcity, EFT_OUTPUT_PER_TILE, OUTPUT_FOOD);

instead of what we use now:

get_city_bonus(pcity, EFT_FOOD_PER_TILE);

Which is IMHO much more readable.

If these things were generalized and you could define your own output using
rulesets, it would make sense to change it. But things currently do not
work that way and I suspect this would complicate the code horribly.

---
Vasco Alexandre da Silva Costa @ Instituto Superior Tecnico, Lisboa




[Prev in Thread] Current Thread [Next in Thread]