Complete.Org: Mailing Lists: Archives: freeciv-dev: February 2003:
[Freeciv-Dev] Re: (PR#2370) Path finding
Home

[Freeciv-Dev] Re: (PR#2370) Path finding

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: undisclosed-recipients:;
Subject: [Freeciv-Dev] Re: (PR#2370) Path finding
From: "Raimar Falke" <rf13@xxxxxxxxxxxxxxxxx>
Date: Thu, 13 Feb 2003 02:04:05 -0800
Reply-to: rt@xxxxxxxxxxxxxx

On Wed, Feb 12, 2003 at 02:07:58PM -0800, Gregory Berkolaiko wrote:
> > Problems:
> >  - quality of path_finding.c (later)
> 
> quality of path_finding.c is superb!  Five stars!  Too good so it stands
> out, so I guess that must be fixed...

You forgot the smiley right? I fixed the worst cases like the 26 lines
macro, wrong function types and so on. I also removed TM_AVERAGE
because I think that there is no clean semantic.

Please add pf_get_path and pf_next_get_position since these are
missing.

> >  - pqueue:
> >    * no comment at all what this is (also bad filename IMHO)
> >    * PQDATUM* suggests a flexibility which isn't there
> >    * INIT_ITEMS, *tiny* shouldn't be public
> 
> please fix

Cleaned up a lot. I battled over naming it "priority queue" or
"heap". Looks like both are equal common.

I think that pqueue should be moved to common.

There is currently no standard for section comments. You used
/* -------------------- generating the map ------------------------ */
I used in cm.c
/****************************************************************************
                           algorithmic functions
*****************************************************************************/

IMHO these - are bad because I can no longer search with "---" for the
next file in a diff.

I also made some other changes like adding #include config.h.

        Raimar

-- 
 email: rf13@xxxxxxxxxxxxxxxxx
 Q:  Do you know what the death rate around here is?
 A:  One per person.

Attachment: pf10.diff.gz
Description: pf10.diff.gz


[Prev in Thread] Current Thread [Next in Thread]