Complete.Org: Mailing Lists: Archives: freeciv-dev: January 2004:
[Freeciv-Dev] Re: (PR#6941) Mission Orders
Home

[Freeciv-Dev] Re: (PR#6941) Mission Orders

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: undisclosed-recipients: ;
Subject: [Freeciv-Dev] Re: (PR#6941) Mission Orders
From: "Arnstein Lindgard" <a-l@xxxxxxx>
Date: Fri, 9 Jan 2004 10:11:20 -0800
Reply-to: rt@xxxxxxxxxxx

<URL: http://rt.freeciv.org/Ticket/Display.html?id=6941 >

New version of Mission Orders, including Orders-9.

+ Small bugfixes.
+ Savegame stores/loads mission and order type.
+ No macros.
+ Rename ORDERS_MOVE to ORDER_MOVE.
+ Cleanup the increasingly unwieldy function update_menus()
  in gtk[12] according to Codingstyle.

+ Absorbing Jasons opinions in PR#7131:

This currently unused enum is removed from the code:

enum goto_route_type {
  ROUTE_GOTO, ROUTE_PATROL
};

And replaced with:

/* For client to determine what sprite to display. */
enum orders_type {
  GOTO_ORDERS, PATROL_ORDERS, STATIONARY_ORDERS
};

Expanding the orders struct:

  struct {
    int length, index;  /* server only */
    bool repeat;        /* The path is to be repeated on completion. */
    bool vigilant;      /* Orders should be cleared if an enemy is met. */
    struct unit_order *list; /* server only */
>   /* For client to display sprites correctly. */
>   enum unit_orders mission; /* The last order in the list. */
>   enum orders_type type;    /* Goto, Patrol, Stationary.   */
  } orders;


Arnstein

Attachment: mission_orders_4.diff.bz2
Description: BZip2 compressed data


[Prev in Thread] Current Thread [Next in Thread]