Complete.Org: Mailing Lists: Archives: freeciv-dev: March 2002:
[Freeciv-Dev] Re: Success at last with Sound #15

[Freeciv-Dev] Re: Success at last with Sound #15

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: Raahul Kumar <raahul_da_man@xxxxxxxxx>
Cc: freeciv development list <freeciv-dev@xxxxxxxxxxx>
Subject: [Freeciv-Dev] Re: Success at last with Sound #15
From: Raimar Falke <hawk@xxxxxxxxxxxxxxxxxxxxxxx>
Date: Thu, 21 Mar 2002 08:00:09 +0100
Reply-to: rf13@xxxxxxxxxxxxxxxxxxxxxx

On Wed, Mar 20, 2002 at 07:58:20PM -0800, Raahul Kumar wrote:
> I've tried your new and improved aclocal.m4. That combined with Per's sound
> patch has finally resulted in a working freeciv with sound for me. 
> The sequence of events was
> tar zxvf freeciv-cvs-Mar-18.tar.bz2 
> cp sound15.diff freeciv/ 
> cp stdsounds.tar.gz freeciv/
> cd freeciv
> tar zxvf stdsounds.tar.gz
> patch < sound15.diff -p1
> cd ..
> cp aclocal.m4 freeciv/
> cd freeciv
> autoheader; aclocal; automake; autoconf; 
> Succeeded well. No problems yet.
> ./configure 
> checking for ngettext in -lc... yes
> checking whether libc's ngettext works at runtime... yes
> checking for GNU xgettext version >= 0.10.38... no
> configure: warning: You may have problems with creating pox files. Please
> update your gettext package.
> checking for GNU msgfmt version >= 0.10.35... no
> configure: error: You are unable to create *.gmo files.
> This is development version which doesn't include them. Please update your
> gettext package. We recommend you versions >= 0.10.38. Or use
> --disable-nls instead.

What is the output of
  msgfmt --version

> I still get this obscure mesage about msgfmt, and my version of gnu gettext 
> is 
> 0.10.40, yet the configure script claims it is < 0.10.38. I'd love to know how
> to check version number of msgfmt, rpm -q msgfmt does not do it.

> After running ./configure --disable-nls
> Sound patch problems
> checking for esd-config... /usr/bin/esd-config
> checking for ESD - version >= 0.0.20... no
> *** Could not run ESD test program, checking why...
> *** The test program failed to compile or link. See the file config.log for 
> the
> *** exact error that occured. This usually means ESD was incorrectly installed
> *** or that you have moved ESD since it was installed. In the latter case, you
> *** may want to edit the esd-config script: /usr/bin/esd-config


> 2: audio_play_sound('m_archers', 'm_generic')
> 2: last message repeated 2 times
> 2: audio_play_sound('m_settlers', 'm_generic')
> 2: last message repeated 2 times

This is ok.

> Odd enough, I see error reminiscent of the CMA about messages being
> repeated two times. A problem with syncronising to the server Per?

I don't understand.


 email: rf13@xxxxxxxxxxxxxxxxx
 Windows: Where do you want to go today?
 Linux: Where do you want to go tomorrow?
 BSD: Are you guys coming or what?

[Prev in Thread] Current Thread [Next in Thread]