Complete.Org: Mailing Lists: Archives: freeciv-dev: March 2002:
[Freeciv-Dev] Success at last with Sound #15

[Freeciv-Dev] Success at last with Sound #15

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: rf13@xxxxxxxxxxxxxxxxxxxxxx, freeciv development list <freeciv-dev@xxxxxxxxxxx>
Subject: [Freeciv-Dev] Success at last with Sound #15
From: Raahul Kumar <raahul_da_man@xxxxxxxxx>
Date: Wed, 20 Mar 2002 19:58:20 -0800 (PST)

I've tried your new and improved aclocal.m4. That combined with Per's sound
patch has finally resulted in a working freeciv with sound for me. 

The sequence of events was

tar zxvf freeciv-cvs-Mar-18.tar.bz2 
cp sound15.diff freeciv/ 
cp stdsounds.tar.gz freeciv/
cd freeciv
tar zxvf stdsounds.tar.gz
patch < sound15.diff -p1
cd ..
cp aclocal.m4 freeciv/
cd freeciv

autoheader; aclocal; automake; autoconf; 

Succeeded well. No problems yet.


checking for ngettext in -lc... yes
checking whether libc's ngettext works at runtime... yes
checking for GNU xgettext version >= 0.10.38... no
configure: warning: You may have problems with creating pox files. Please
update your gettext package.
checking for GNU msgfmt version >= 0.10.35... no
configure: error: You are unable to create *.gmo files.
This is development version which doesn't include them. Please update your
gettext package. We recommend you versions >= 0.10.38. Or use
--disable-nls instead.

I still get this obscure mesage about msgfmt, and my version of gnu gettext is 
0.10.40, yet the configure script claims it is < 0.10.38. I'd love to know how
to check version number of msgfmt, rpm -q msgfmt does not do it.

After running ./configure --disable-nls

Sound patch problems

checking for esd-config... /usr/bin/esd-config
checking for ESD - version >= 0.0.20... no
*** Could not run ESD test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means ESD was incorrectly installed
*** or that you have moved ESD since it was installed. In the latter case, you
*** may want to edit the esd-config script: /usr/bin/esd-config

This after I checked my esound libraries with

rpm -q esound

I have not moved my esound libraries. As before, Mandrake 8.0 with upgraded gnu

make -j3


2: audio_play_sound('m_archers', 'm_generic')
2: last message repeated 2 times
2: audio_play_sound('m_settlers', 'm_generic')
2: last message repeated 2 times

Odd enough, I see error  reminiscent of the CMA about messages being repeated
two times. A problem with syncronising to the server Per? I've finally got some
nice sound effects with SDL. I'd like the problem with ESD fixed.

Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®

[Prev in Thread] Current Thread [Next in Thread]