Complete.Org: Mailing Lists: Archives: linux-help: May 2006:
[linux-help] Re: network unreachable

[linux-help] Re: network unreachable

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: linux-help@xxxxxxxxx
Subject: [linux-help] Re: network unreachable
From: Jeff Vian <jvian10@xxxxxxxxxxx>
Date: Tue, 02 May 2006 18:34:32 -0500
Reply-to: linux-help@xxxxxxxxx

On Tue, 2006-05-02 at 01:41 -0500, Tom Hull wrote:
> Jonathan Hall wrote:
> > Sounds like hardware to me.
> > 
> > Does the link light come on (either on the NIC, or on the switch) when the
> > cable is plugged in?
> Both lights come on. Speed is 100mbs. Don't see any blinking when I run
> something like:
>    ping -i 0 -f -I eth0 -r
> which floods out thousands of ping packets. Seems like the hardware
> level is functioning, but something is blocking data transmission.
> Similar command from other end doesn't blink light either, so receipt
> also seems to fail.
> Could be hardware, I suppose, but doesn't seem all that likely on a
> new machine that had been working smoothly. What else could it be?
> One difference between this machine and others is that netstat -r
> shows MSS = 0 here vs. 40 on others. Haven't figured out how to
> set/change that, even though route(8) suggests it should work.
Just on the off chance, and to rule out one other problem.
Have you tried a different network cable?
Have you tried a different port on the switch?

You can (at least in Fedora) use ethtool to look at and change settings
on an adapter.  Pre-FC5 I think it was miitool that did similar things.

> >>I have a problem on a recently built Ubuntu Linux system. Sometime in
> >>the last day or two the machine lost its network connection. Ethernet
> >>controller is on the motherboard. It is configured with a static
> >>address, and can ping that address but nothing else on the local
> >>network. Changing cable and/or port on the otherwise working switch
> >>has no effect. We had some trouble yesterday when my gateway machine
> >>couldn't get a DHCP address from Cox for a period of several hours.
> >>Not sure whether the Ubuntu machine problem occurred at that time,
> >>since I didn't notice it until much later. I've rebooted since then.
> >>Don't see anything obviously wrong, e.g. in netstat -r or iptables -L.
> >>
> >>Aside from hardware, is there anything you can think of that might
> >>cause a Linux machine to effectively disconnect itself from a local
> >>network?
> >>
> >>Thanks.

-- This is the linux-help@xxxxxxxxx list.  To unsubscribe,

[Prev in Thread] Current Thread [Next in Thread]