Complete.Org: Mailing Lists: Archives: linux-help: May 2006:
[linux-help] Re: network unreachable

[linux-help] Re: network unreachable

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: linux-help@xxxxxxxxx
Subject: [linux-help] Re: network unreachable
From: Leland Weathers <leland@xxxxxxxxxxxxxx>
Date: Wed, 03 May 2006 07:10:43 -0500
Reply-to: linux-help@xxxxxxxxx

Tom Hull wrote: Jeff Vian wrote: On Tue, 2006-05-02 at 01:41 -0500, Tom Hull
wrote: Just on the off chance, and to rule out one other problem. Have you
tried a different network cable? Have you tried a different port on the
switch? yes. yes. tried booting ubuntu live disc. network still unreachable.
iptables -L -n shows all rule sets as ACCEPT, which I take to mean no
You could verify the no "firewalling" by either doing a tcpdump on the
interface when you do a ping.
dmesg shows entries like: NETDEV WATCHDOG: eth0: transmit timed out eth0: no
IPv6 routers present kernel 2.6.12; driver for eth0 is forcedeth.c 0.41 You
can (at least in Fedora) use ethtool to look at and change settings on an
adapter. Pre-FC5 I think it was miitool that did similar things. not easy to
copy the output, but ethtool's basic output looks not unreasonable (omitting
a couple of lines): Supported ports: [ MII ] Supports auto-negotiation: yes
Advertised auto-negotiation: yes Speed: 100Mb/s Duplex: half Port: MII
PHYAD:1 Transceiver: externel Auto-negotiation: on Supports Wake-on: g
Wake-on: d Link detected: yes netstat -r reports MSS = 0; don't know whether
that means no maximum segment size or 0, which could choke it; my Red Hat
machines use 40. got a chassis intrusion message first time I rebooted after
problem; reset and message went away; would be weird if BIOS disabled
ethernet because of the chassis instrusion detect. I have a problem on a
recently built Ubuntu Linux system. Sometime in the last day or two the
machine lost its network connection. Ethernet controller is on the
motherboard. It is configured with a static address, and can ping that
address but nothing else on the local network. Changing cable and/or port on
the otherwise working switch has no effect. We had some trouble yesterday
when my gateway machine couldn't get a DHCP address from Cox for a period of
several hours. Not sure whether the Ubuntu machine problem occurred at that
time, since I didn't notice it until much later. I've rebooted since then.
Don't see anything obviously wrong, e.g. in netstat -r or iptables -L. Aside
from hardware, is there anything you can think of that might cause a Linux
machine to effectively disconnect itself from a local network? Thanks. 

-- This is the linux-help@xxxxxxxxx list.  To unsubscribe,

[Prev in Thread] Current Thread [Next in Thread]