Complete.Org: Mailing Lists: Archives: freeciv-dev: February 2003:
[Freeciv-Dev] Re: (PR#2370) Path finding

[Freeciv-Dev] Re: (PR#2370) Path finding

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: rf13@xxxxxxxxxxxxxxxxx
Subject: [Freeciv-Dev] Re: (PR#2370) Path finding
From: "Gregory Berkolaiko" <Gregory.Berkolaiko@xxxxxxxxxxxx>
Date: Thu, 27 Feb 2003 13:51:34 -0800
Reply-to: rt@xxxxxxxxxxxxxx

Patch with latest corrections attached.

Below I list the few cases where I did _not_ do what Mike suggested.


Quoting Gregory Berkolaiko <Gregory.Berkolaiko@xxxxxxxxxxxx>:

> On Wed, 26 Feb 2003, Mike Kaufman wrote:
>  *   best path: a path which has the minimal total_CC. If two paths
>  *   have equal total_CC the behavior is undefined.
> > not sure I like this. Is it possible to have this? If so define a 
> > behavior, like: the last calculated or the first in the queue or 
> > whatever is picked as the path.
> "the last calculated" is still undefined as far as you, The User, are 
> concerned.

no changes here.

> *     - TM_NONE: total_MC = sum of MC
> > lose the "-"
> I like them and see no reason to lose them.

no changes.

> > my previous comment about compressing 3-line comments to 1-line comments 
> > still stands.
> I don't mind.  See what Raimar says (I suspect he does mind).

I consulted our style guide and consequently removed all opening empty lines in
the comments (apart from the main comment)

> > perhaps this should be renamed pf_get_best_path() then?
> Whole PF is about best paths.

not changed.

>  * Below iterator is mostly for use by AI, iterates through all positions
>  * on the map, reachable by punit, in order of their distance from punit.
>  * Returns info about these positions via the second field.
>  */
> #define simple_unit_path_iterator(punit, position) {  
> > ALL positions?!
> it says:
> all positions on the map, reachable by punit,

no changes.

> #define simple_unit_overlap_path_iterator(punit, position) {   
> > ok, after reading the comment, I'm confident that there's a better name 
> > for this, for example: simple_unit_oncoast_path_iterator or 
> > simple_unit_landocean_path_iterator
> simple_unit_bombard_path_iterator ?
> they all pretty crap I must say.

no changes.


Attachment: pf27.diff.gz
Description: pf27.diff.gz

[Prev in Thread] Current Thread [Next in Thread]