Complete.Org: Mailing Lists: Archives: linux-help: April 2002:
[linux-help] Repost - Install of Redhat 7.2 on SiS box - with solution

[linux-help] Repost - Install of Redhat 7.2 on SiS box - with solution

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: linux-help@xxxxxxxxx
Subject: [linux-help] Repost - Install of Redhat 7.2 on SiS box - with solution
From: bbales <bbales@xxxxxxxxxxx>
Date: Mon, 22 Apr 2002 15:45:09 -0500
Reply-to: linux-help@xxxxxxxxx

I am reposting this along with the solution since I have received eight 
requests from people with the same problem.

Problem summary first.  Attempting to install RH7.2 on some Silicon 
Integrated Systems (SiS) computers results in a kernel panic shortly after 
the install begins.

An unnamed responder to my problem wrote directly to me, and I later posted 
the response, but it must be hard to find. 

He told me to start the install by typing "linux mem=128m"  Actually this 
didn't work for me, perhaps since my board shared 32M with the graphics 
board, but "linux mem=64m" did work.

Another person with the same problem wrote to say he turned off everything in 
the bios and started turning them back on until it failed.  It failed with 
power management turned on and loaded with power management off.  I would try 
the "linux mem=64m" first.

The original problem posting follows:

Trying to install RedHat 7.2 on a Silicon Integrated Systems (SIS) 800 MHz
Athlon, large disk, 128MB memory.  I have three of these and successfully
installed 7.2 on two of them by using "nofb" (no frame
buffers).  The third won't even get past the boot disk. Made two more boot 
disks - same result.  It sets up the choices (enter, nofb,
lowres, expert, etc, ) loads initrd.img and vmlinuz from floppy, message "Ok
loading the kernel," then the page shown below appears. Changed setup to boot 
from CDROM and get the same result - loads initrd.img and
vmlinuz then gives the messages shown below. I got out the old 7.0 disks and 
floppy and it loaded easily.  Have a good 7.0
system with KDE windows, but it doesn't have the drivers for all the SIS
peripherals (sound, ethernet, and others, which are all on the mainboard), so
7.0 is worthless for this machine. The bios setups on all machines are 
identical. Can anyone make any sense out of the page below?  Any help would 
be greatly appreciated.

mtrr: v1.40 (20010327) Richard Gooch (rgooch@xxxxxxxxxxxxx)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.18 entry at 0xfdb01, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router SIS [1039/0008] at 00:01.0
Linux Net4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
invalid operand: 0000
CPU:   0
EIP:     0010:[<c01122d1>]
EFLAGS: 00010206
eax: c0101c78    ebx: c7800000   ecx:   88a32000   edx:   c0101000
esi:   c1232000   edi: 06ff0000     ebp:   00000000   esp:   c135ff54
ds:   0018     es:   0018    ss: 0018
Process swapper (pid: 1, stackpage=c135f000)
stack: 06ff1000 00001000 06ff0000 c00fc390 88a32000 c0101c78 00000010 c7800000
          c1232000 06ff0000 00000000 c0112523 c7800000 3f7f0000 c1232000
          c822184c c00fc390 00000014 c7800000 c123184d c0233a70 06ff0000
Call Trace: [<c7800000>] [<c0112523>] [<c7800000>] [<c822184c>] [<c7800000>]
    [<c0105000>] [<c0105201>] [<c0105000>] [<c0105642>] [<c01051f8>] Code: 0f 
0b 8b 5c 24 14 85 db e9 31 01 00 00 89 f6 b8 f4 ff ff ff
 <0>Kernel panic: Attempted to kill init!

-- This is the linux-help@xxxxxxxxx list.  To unsubscribe,

[Prev in Thread] Current Thread [Next in Thread]