Complete.Org: Mailing Lists: Archives: freeciv-dev: December 2004:
[Freeciv-Dev] (PR#11336) [Patch] movetype.[ch]

[Freeciv-Dev] (PR#11336) [Patch] movetype.[ch]

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: marko.lindqvist@xxxxxxxxxxx
Subject: [Freeciv-Dev] (PR#11336) [Patch] movetype.[ch]
From: "Gregory Berkolaiko" <Gregory.Berkolaiko@xxxxxxxxxxxxx>
Date: Wed, 29 Dec 2004 11:04:20 -0800
Reply-to: bugs@xxxxxxxxxxx

<URL: >

>   Renamed is_water_unit() -> is_sailing_unittype() for consistency. We 
> now have:
>   is_ground_unit() & is_ground_unittype(),
>   is_air_unit() & is_air_unittype(),
>   is_heli_unit() & is_heli_unittype(),
>   is_sailing_unit() & is_sailing_unittype()

Please consider the following:
is_ground and is_air refer to the substance in/on which the movement is
is_sailing refers to the way the movement is done

So I think is_sea_unit is better (and shorter too!)

The reason I am asking is because I could never remember the name

[Prev in Thread] Current Thread [Next in Thread]