Complete.Org: Mailing Lists: Archives: freeciv-java: October 2001:
[FreeCiv-Java] Re: compiling

[FreeCiv-Java] Re: compiling

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: "jFreeCiv" <freeciv-java@xxxxxxxxxxx>
Subject: [FreeCiv-Java] Re: compiling
From: "Brian Duff" <Brian.Duff@xxxxxxxxxx>
Date: Thu, 25 Oct 2001 23:33:24 +0100

Hi Alex,

Excellent, I'm glad it all compiled :) Sorry about the hardcoded data path
stuff: I was having some problems at one point, and never got round to
removing the nasty hardcoded path.

As far as the misplaced class goes, I seem to remember it belongs in
org.freeciv.client.ui; I must have neglected to update its package header.

For the data files, I never re-added them after the move up to, as
I was going to wait until 1.12 had been released before adding them. Theres
no reason now not to add a 1.12 snapshot of the data files to our cvs
repository, and we can update them when necessary. I'll go ahead and do this
as soon as I have a chance, and also have a go at fixing the buildfile.



-----Original Message-----
From: freeciv-java-bounce@xxxxxxxxxxx
[mailto:freeciv-java-bounce@xxxxxxxxxxx]On Behalf Of Alexander Braun
Sent: 23 October 2001 17:45
To: Brian Duff; jFreeCiv
Subject: [FreeCiv-Java] compiling

Hi Brian,

yeah I first tried using ant, even got your toolbox to compile, but then
some issue diverted me to compile it manually, forgot what. The compiling
went quite smooth, exempting a couple of smaller issues and one "serious"
issue (i.e. one that needs to be decided): the file
org/freeciv/client/ui/UnitStackDisplay has (had) a package declaration
org.freeciv.client . So, I changed it to package org.freeciv.client.ui and
it worked, but I haven't yet looked at the code closely enough to decide
where that file should actually go.

But otherwise, compile went smooth. Now I'm only stuck trying to get the
data files, as they're empty in your cvs tree. Oh yeah, and you apparently
hard-coded your absolute path to the data dir, forgot where that was. I just
use -D, works fine enough.

Now that was pretty much everything that happened to me compiling, I guess
"...that's a little more information than you needed, Vince" :-)

But perhaps someone else encountered similar problems, so thats why.

Anyways, I'll check out the data files and have a look at the client.



Lotto online tippen! Egal zu welcher Zeit, egal von welchem Ort.
Mit dem WEB.DE Lottoservice.

[Prev in Thread] Current Thread [Next in Thread]