Complete.Org: Mailing Lists: Archives: freeciv-dev: February 2003:
[Freeciv-Dev] Re: (PR#2370) Path finding
Home

[Freeciv-Dev] Re: (PR#2370) Path finding

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: Raimar Falke <rf13@xxxxxxxxxxxxxxxxx>
Cc: Freeciv Development List <freeciv-dev@xxxxxxxxxxx>
Subject: [Freeciv-Dev] Re: (PR#2370) Path finding
From: Gregory Berkolaiko <Gregory.Berkolaiko@xxxxxxxxxxxx>
Date: Fri, 21 Feb 2003 15:04:47 +0000 (GMT)

On Thu, 20 Feb 2003, Raimar Falke wrote:

> > So I propose:
> > MC - move cost of a single move
> > EC - extra cost of a single tile
> > total_MC - (effective) move cost of the whole path
> > total_EC - extra cost of the whole path
> > total_CC - combined cost of the whole path (formerly COP)
> > 
> > Formulae:
> > in TM_NONE
> >   total_MC = sum of MC
> > in TM_CAPPED 
> >   total_MC = sum of MIN(MC, move_rate)
> > in TM_*_TIME
> >   total_MC = ((turn + 1) * move_rate - moves_left)
> > 
> > total_CC = PF_TURN_FACTOR * total_MC + move_rate * total_EC
> > 
> > 
> > This naming scheme is also full of abbreviations but it is more ordered:
> > total_ means it referes to the whole path.  No total_ means it's of one 
> > step/tile.
> 
> I like it. Really.

so I put it in.  But I think I'd prefer not to use abbreviations too much, 
for example callbacks should be:
get_move_cost
get_extra_cost
 and maybe
get_tile_behavior

I think it would be more user-friendly

G.



[Prev in Thread] Current Thread [Next in Thread]