Complete.Org: Mailing Lists: Archives: freeciv-dev: February 2003:
[Freeciv-Dev] Re: (PR#3423) Clear city description

[Freeciv-Dev] Re: (PR#3423) Clear city description

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: bursig@xxxxxxxxx
Subject: [Freeciv-Dev] Re: (PR#3423) Clear city description
From: "Raimar Falke" <rf13@xxxxxxxxxxxxxxxxx>
Date: Sat, 15 Feb 2003 03:15:19 -0800
Reply-to: rt@xxxxxxxxxxxxxx

On Sat, Feb 15, 2003 at 02:38:23AM -0800, Rafa³ Bursig wrote:
> >  - the function should be renamed to prepare_show_city_descriptions or
> >  start_show_city_descriptions or something like this
> I don't care what will be total name of this function but word "clear" 
> should be in it, becouse it give you description what this function 
> should do.

No. This is wrong. This is too gui-sdl centric. With the new function
we provide a hook which a GUI can use to prepare certain things before
show_city_descriptions starts. That gui-sdl takes this opportunity to
clear its old description in this function doesn't belong in the
common code in the form of the function name.


 email: rf13@xxxxxxxxxxxxxxxxx
  What's nice about GUI is that you see what you manipulate.
  What's bad about GUI is that you can only manipulate what you see.

[Prev in Thread] Current Thread [Next in Thread]