Complete.Org: Mailing Lists: Archives: discussion: May 2000:
[aclug-L] Re: Linux Question!!

[aclug-L] Re: Linux Question!!

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: discussion@xxxxxxxxx
Subject: [aclug-L] Re: Linux Question!!
From: Greg House <ghouse@xxxxxxxxxxxxx>
Date: Sun, 14 May 2000 22:36:27 -0500
Reply-to: discussion@xxxxxxxxx

Mohammad Islam <sohel@xxxxxxxxxxxxx> wrote:

> I have a question about Caldera OPenLinux. At work we installed Caldera
> Openlinux 2.4 (Kernel 2.2.14)
> The machine has two Qlogic Fibre Chanel Host adapter cards. We
> downloaded the source for the driver (The Qlogic website said its for
> RedHat 6.0/6.1) and compiled it. Now when we rebotted the machine..the
> kernel tried to load the module for the qlogic cards and come up with
> kernel panic...and no root prompt. 

Where do you work?

I take it you're using the beta driver from Qlogic instead of the driver for
the qlogic cards which comes with the 2.2.3 and higher kernels. The default
driver will work fine with ISP2100/2200 cards, although the performance seems
very slow. I haven't tried Qlogic's beta driver. I'd hoped it's performance
would be better, but haven't gotten around to testing it yet.

If you have JNI Emerald series FC cards (FCE-3210/6410) , JNI has a Linux
driver for them as well. I have some of the cards (at work, LSI Logic) and am
intending to test them out sometime in the next couple of weeks.

I've been using Linux systems with FC disk arrays for awhile now and aside from
some weirdness about device detection and poor performance, the default driver 
written by Chris Loveland at UNH, has worked pretty well. With Chris's
assistance, I've tried to make some changes to the driver to improve it's
performance (increasing queue depth, etc) without much success. The performance
improved, but it appeared to make the system unstable. I kept getting system
hangs with the changes in place, but the system I was using wasn't exactly a
wonderful piece of equipment (something cobbled together for our lab), and
fixing a broken driver isn't exactly my primary job (or line of expertise), so
we didn't persue it any further at the time. I tried his newer version more
recently on a Sparc Linux system and after having a little trouble
getting it to build (they didn't ship that module with the stock Sparc
version of RedHat 6.2, maybe there's a reason), I couldn't get it to detect
any devices. As often hapens, I needed to go work on something higher priority
before I could really figure out what the problem was.

The beta driver by Qlogic has only been available for a couple of months, and
even less for the JNI driver, and I've been busy with other things. I'm hoping
to get back to testing those two drivers soon. 

I'd be very interested in hearing the results of your Linux FC work.

Oh yeah, regarding your problem... You need to boot from a rescue disk so you
can mount your file system and fix things. The easiest way to get going is
proably to just rename the qlogic driver's module to another location so it
can't be loaded. Then you should be able to reboot your real system and rebuild
your kernel to get things working. I had a similar problem with the default
qlogic driver (earlier version). What was happening was that it was loading
that driver before the driver for the SCSI boot disk in the machine I was
using. That invalidated the device mapping (sda, sdb, etc) and it would panic
because it couldn't find the root device. The solution at the time was to turn
off kernel module auto loading and loading the module in rc.local, well after
when the driver for the boot device's SCSI card was loaded. Perhaps there's a
more elegant solution, but I never found one at the time. Because of this, I
always try to test kernel modules I'm not familiar with using insmod before I
let a boot auto load them.


-- This is the discussion@xxxxxxxxx list.  To unsubscribe,

[Prev in Thread] Current Thread [Next in Thread]