Complete.Org: Mailing Lists: Archives: discussion: November 1999:
[aclug-L] Re: Program needs

[aclug-L] Re: Program needs

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: <aclug-L@xxxxxxxxxxxx>
Subject: [aclug-L] Re: Program needs
From: "kai & steven Hallacy" <enginear@xxxxxxxxx>
Date: Wed, 17 Nov 1999 12:21:53 -0600
Reply-to: aclug-L@xxxxxxxxxxxx

I didn't create the program.  The program, called Nserver, comes
from  I'm using the program to simulate a super
scout 2 robot for my ECE738 (Embedded Systems).  I've been
speaking to a person at and he hasn't repied to my
email message since yesterday.

First, I tried the most current version of Nserver.  Running the
current version resulted in a segmetation fault.
Next,  I called the support group at and got in
touch with Jake.  Shown below is the email conversation between
Jake and I.   Yesterday, I called him and he told me to use a
previous version of Nserver.   The previous version of the
program has problems finding the libraries.



This message contains an file attachment which has the listing of
the /usr/lib directory.

-----Original Message-----
From: Jake Sprouse <jake@xxxxxxxxxx>
To: kai & steven Hallacy <enginear@xxxxxxxxx>
Date: Monday, November 15, 1999 2:10 PM
Subject: Re: Running Nserver in Debian Linux


Is the write-protect tab of your floppy disk set?

Another thing you can try is using the mtools to access your
floppy drive
-- e.g. `mdir` is the equivilant of the DOS DIR command, and
mwrite will
copy files to the floppy.  You can use these without the floppy
being a mounted filesystem.


J. Jake Sprouse, Software Engineer
Nomadic Technologies, Inc.
(650) 988-7200 x216

On Mon, 15 Nov 1999, kai & steven Hallacy wrote:

> When I run bt, I get the following:
> #0    0x0 in ?? ()
> #1    0x8050b5b in frame_dummy ()
> #2    0x804ea55 in        ()
> #3    0x401690c1 in       ()
> The uname -a command returns:
> Linux debian 2.0.36 #2 Sun Feb 21 15:55:27 EST 1999 i486
> I saved the contents of /usr/lib to a temporary file (temp)
because I
> wanted to transfer the file to this computer.  However when I
tried to
> write this file to the /mnt/floppy (my floppy drive), I wasn't
> to.  I got the following error:
> cp: cannot create regular file '/mnt/floppy/temp': Read-Only
file system
> I tried to change the rwx attribute of /mnt/floppy, but I got
an error
> saying its only a read only file system.  WHAT A PAIN IN
> Please help.
> PS:  I tried different graphic modes 800x600, ect.  Also, I
tried the
> BASH and TCSH shell.  No difference!
> -----Original Message-----
> From: Jake Sprouse <jake@xxxxxxxxxx>
> To: kai & steven Hallacy <enginear@xxxxxxxxx>
> Date: Monday, November 15, 1999 1:03 PM
> Subject: Re: Running Nserver in Debian Linux
> Hi Steven,
> when you get the seg fault, type the 'bt' command at the gdb
prompt.  The
> output of this command is what I'm looking for.
> I would also like to see the output of the `uname -a` command
which gives
> information about your OS & kernel versions.
> Finally, doing an `ls -l` of /usr/lib will show what versions
of libc you
> are using.  Send the output of that as well.
> You can get documentation on GDB with the info system (assuming
> installed with your distro): `info gdb`  GDB is an incredibly
useful tool.
> Thanks,
> --Jake
> J. Jake Sprouse, Software Engineer
> Nomadic Technologies, Inc.
> (650) 988-7200 x216
> On Mon, 15 Nov 1999, kai & steven Hallacy wrote:
> > Hello Jake,
> >
> > My name is Steven Hallacy.  I trying to use Nserver at Home.
I have a Debian
> > Installation of Linux and I get a segmentation fault when I
run Nserver.
> >
> > I downloaded "host-2.6.9-i486-unknown-linux.tgz" from
> >
> > I ran Nserver in gdb and got the following:
> >
> > Program received signal SIGSEGV, Segmentation fault.
> > 0x0 in ?? ()
> >
> >
> > Then I tried:
> >
> > gdb) break 0
> >
> > and gdb returned the following:
> >
> > No line 0 in file "init.c"
> >
> >
> > I not very familiar with gdb. Please help.
> >
> >
> > Thanks,
> >
> > Steven Hallacy
> >
> >
> >

-----Original Message-----
From: Jeff <schaller@xxxxxxxxxxxxx>
To: aclug-L@xxxxxxxxxxxx <aclug-L@xxxxxxxxxxxx>
Date: Wednesday, November 17, 1999 5:40 AM
Subject: [aclug-L] Re: Program needs

>On Wed, 17 Nov 1999, kai & steven Hallacy wrote:
>> I appreciate everyones help.  I think there were six libraries
>> that my program could not open. Some were in the
>> directory.  I copy them to the /usr/lib directory.  However,
>> could not be found (, so I used the next best thing
>> The program finally gave me a segmentation fault.
>> Has anyone out there had this problem? Is this a Debian
>> Should I consider changing to a different linux installation?
>> program runs at school on redhat linux.
>Ack.  You should not have to copy library files from /usr/X11*
>/usr/lib ... the compiler should include /usr/X11 in its path
>places to look for libraries).  You can do this with something
> gcc -L/usr/X11R6/lib
>Another thought hit me regarding the math library: is the
>file that you have right now just a link?  Could you send the
>of an: ls -l /lib/
>I'm worried that maybe your real math library got trashed and so
>just have a dangling link pointing to it.  Otherwise (if it's a
>file), you're OK.  If a normal compile (well, link) fails
because it
>didn't find the math functions, add a "-lm" to the compile line:
> gcc -o file file.c -lm
>"It's not just the apocalypse, it's the humidity." - Joel of

[Prev in Thread] Current Thread [Next in Thread]