Complete.Org: Mailing Lists: Archives: linux-help: November 2003:
[linux-help] Re: Problem Booting Kernel 2.6.0

[linux-help] Re: Problem Booting Kernel 2.6.0

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: linux-help@xxxxxxxxx
Subject: [linux-help] Re: Problem Booting Kernel 2.6.0
From: Jeff Vian <jvian10@xxxxxxxxxxx>
Date: Wed, 12 Nov 2003 15:11:18 -0600
Reply-to: linux-help@xxxxxxxxx

I run grub so my config would be different.
However, I used to run lilo, and I am not familiar with the first line 
of your lilo.conf file. "lba32"  I never saw that in any of the files I 
worked with.

I am not sure if this is the issue, but AFAIK  winXP is like NT in that 
it does not like booting from the linux boot loader.  I have had good 
luck setting linux up to boot from the XP boot loader, but have had no 
luck the other way around.  According to your lilo.conf file you are 
setting it up to boot XP from /dev/hda1, and putting the lilo image on 
the boot sector of hda.

This site has good instructions for setting up dual boot with XP

Justin Hamm wrote:

>I have come across a problem (others might have had similar probs) in
>relation to kernel 2.6.0. I'm running LILO 22.5.8 with Debian unstable
>with security updates, kernel 2.6.0test6. 
>I have a problem booting to 2.6.0, here is the error I receive:
>-- snip --
>VFS: Cannot open root device "1602" or unknown-block(22,2)
>Please append a correct "root=" boot option
>Kernel panic: VFS: Unable to mount root fs on unknown-block(22,2)
>-- snip --
>Here is my lilo.conf file:
>-- snip --
>       label=Linux
>       read-only
>       label=LinuxOLD
>       read-only
>       optional
>       label="WinXP(hda1)"
>-- snip --
>I have gone in and tried other suggestions from other lists.. such as
>adding a line append="root=/dev/hdc2" which had no effect, Also tried
>running root=1602 just for giggles but it also had no effect (as I
>didn't think it would.. but I ran outta options).
>Has anyone else experienced this problem when switching to 2.6.0?
>If anyone needs additional information, I'll be happy to provide it.
>Also, After I run /sbin/lilo to update any changes made, it keeps giving
>me: "Warning: The boot sector and map file are on different disks."
>Which I'm pretty sure I understand as a harmless warning, most dualboot
>systems could result in the same if lilo wasn't installed on the Linux
>partition... So I guess ignore that..
>Thank you!
>-- This is the linux-help@xxxxxxxxx list.  To unsubscribe,

-- This is the linux-help@xxxxxxxxx list.  To unsubscribe,

[Prev in Thread] Current Thread [Next in Thread]