Complete.Org: Mailing Lists: Archives: freeciv: July 1999:
[Freeciv] Re: FreeCiv 1.8.1 gtk Amiga

[Freeciv] Re: FreeCiv 1.8.1 gtk Amiga

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: freeciv@xxxxxxxxxxx
Cc: freeciv@xxxxxxxxxxx, kim.sindalsen@xxxxxxxxxxxx
Subject: [Freeciv] Re: FreeCiv 1.8.1 gtk Amiga
From: sebauer@xxxxxxxxxxx (Sebastian Bauer)
Date: Mon, 26 Jul 1999 10:07:14 +0100

Hello David

>> Does it hang if you are attack a unit? I've tried to solve the problem
>> but it seems that I was not succesful...
>> I don't know where the bug is. Eighter in Freeciv, xGeek, in the
>> ixemul.library or somewhere others.
>> But I don't believe that the bug is in freeciv because I never read
>> something like this in the freeciv ML from users using othere OSes.
> Maybe a problem in common/shared.c:myusleep() ?
> I seem to recall someone (Amiga user even?) reporting hangs
> when the select() method was used to sleep, hence the usleep() 
> method.  Does your config.h define HAVE_USLEEP?

Yes, it was my try to solve the problem and I thought it worked.
But now at least two people told me that they have the same problem
again so the bug is still in (but probably not in freeciv)

Sebastian Bauer

[Prev in Thread] Current Thread [Next in Thread]