Complete.Org: Mailing Lists: Archives: freeciv: January 1999:
[Freeciv] Overcomming Xaw segfault

[Freeciv] Overcomming Xaw segfault

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: freeciv@xxxxxxxxxxx
Subject: [Freeciv] Overcomming Xaw segfault
From: "Geoffrey T. Cheshire" <gches@xxxxxxxxxxx>
Date: Sun, 31 Jan 1999 12:27:50 -0700

Hi all,

I'm brand new to freeciv (and the civ games in general) and am having
what I think is the Xaw incompatability problem.  I'm running a fairly
standard RedHat 5.1/2 system.  I show Xaw and Xaw3d in my libs, but I'm
guessing Xaw is not really the classic Xaw (and I can't find the old Xaw
on the net either).

So,  when I compile the sources, I get a segfault right when I try to
execute the client.  I grabbed the rpm's for the server & client and
tried that.  This worked a little better -- the client would fire up,
but as soon as I got through setting the server & trying to start the
game, the thing would segfault again.

Can anyone offer me a more step-by-step way to try and get the client
running?  Should I try the GTK+ version?  Where is it?

Geoffrey T. Cheshire <gches@xxxxxxxxxxx>

[Prev in Thread] Current Thread [Next in Thread]