Complete.Org: Mailing Lists: Archives: freeciv-dev: August 2004:
[Freeciv-Dev] Re: (PR#9869) Bug: DDEBUG changes savegames

[Freeciv-Dev] Re: (PR#9869) Bug: DDEBUG changes savegames

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: undisclosed-recipients: ;
Subject: [Freeciv-Dev] Re: (PR#9869) Bug: DDEBUG changes savegames
From: "Gregory Berkolaiko" <Gregory.Berkolaiko@xxxxxxxxxxxxx>
Date: Mon, 30 Aug 2004 10:06:32 -0700
Reply-to: rt@xxxxxxxxxxx

<URL: >

On Sun, 29 Aug 2004, Jason Short wrote:

> <URL: >
> Gregory Berkolaiko wrote:
> > I am not sure which is the better way to fix this: do temporary
> > assignments inside index_to* functions or do it in the caller.  The first
> > way might give more work to compiler (optimizing), the second will give
> > more work to us (reviewing all uses).
> We can't do temporary assignments unless we make it an inline function. 
>   Changing the users is fine but we also have to rename it as 
> INDEX_TO_MAP_POS.  I would prefer the former but either is fine.

I am confused.  First, why cannot we do temp assignments in a macro 
(unless we want it as an lvalue or something)

#define blah(a, b) {int c = a; b += c; b *= c;}

Second, if we change the users, why should we rename it? (Or is it because 
of the new guidelines macros vs inlines?)

Third, which one you'd actually prefer, to make it inline?

Fourth, why don't you make a patch ;)


[Prev in Thread] Current Thread [Next in Thread]