[Freeciv-Dev] (PR#6451) Solaris compiler warning
[Top] [All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
[bretta - Thu Oct 9 12:00:09 2003]:
> I just saw an interesting compiler warning during a build on Solaris:
>
> if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I./../common -I./../ai -I../intl
> -I../common/aicore -I./userdb -g -O2 -Wall -Wpointer-arith
> -Wcast-align -Wmissing-prototypes -Wmissing-declarations -MT srv_main.o
> -MD -MP -MF ".deps/srv_main.Tpo" \
> -c -o srv_main.o `test -f 'srv_main.c' || echo './'`srv_main.c; \
> then mv ".deps/srv_main.Tpo" ".deps/srv_main.Po"; \
> else rm -f ".deps/srv_main.Tpo"; exit 1; \
> fi
> In file included from ../common/capability.h:17,
> from srv_main.c:47:
> ../common/shared.h:86:1: warning: "WRAP" redefined
> In file included from /usr/include/sys/termio.h:13,
> from srv_main.c:32:
> /usr/include/sys/termios.h:251:1: warning: this is the location of the
> previous definition
>
>
> Looks like "WRAP" is already used by termio.h.
WRAP is being defined as an arbitrary integer (something do do with page
sizes, I imagine).
Freeciv's WRAP macro could be renamed WRAP0 or FC_WRAP.
jason
- [Freeciv-Dev] (PR#6451) Solaris compiler warning,
Jason Short <=
|
|