[Freeciv-Dev] Re: nouja's removing annoying popups patch
[Top] [All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
On Tue, Nov 19, 2002 at 12:45:09PM +0000, Per I. Mathisen wrote:
> This is an old patch from 1.12.x which Reinier wrote, and which I've
> updated and intend to commit. It is very short, and the only bad thing
> about it is that it adds two more options to an already crowded local
> options dialog. But then, I think it is a mistake to have two tileset
> choices there, and that we should remove the metaserver option until we
> have a freely available metaserver. And we can always expand it to two
AFAIK you can get the metaserver code and setup your own one.
> +bool ask_city_name = 1;
> +bool popup_new_cities = 1;
TRUE;
> + GEN_BOOL_OPTION(ask_city_name, N_("Prompt for city names")),
Can we rename this to prompt_city_name?
> + } else {
> + struct packet_unit_request req;
Add a blank line.
> + req.unit_id = packet->id;
> + sz_strlcpy(req.name, packet->name);
> + send_packet_unit_request(&aconnection, &req, PACKET_UNIT_BUILD_CITY);
> + }
> return;
Raimar
--
email: rf13@xxxxxxxxxxxxxxxxx
"When C++ is your hammer, everything looks like a thumb."
-- Steven M. Haflich
|
|