[Freeciv-Dev] Re: jjm: Fix bug in recent transitive unit upgrade patch.
[Top] [All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
At 2000/04/23 01:05 , David Pfitzner wrote:
>Anyway, while doing so I was disconcerted to find that we have two
>functions called "upgrade_unit":
>-- a "public" upgrade_unit() in server/unithand.h
>-- a static upgrade_unit() in cityturn.c (which doesn't include
>These functions have different signatures and very different effects
>(one returns a value, the other actually upgrades a unit), and I
>think one of them should be renamed to avoid potential confusion.
Absolutely! Here's a patch which renames the static one in cityturn.c. It
also renames the static upgrade_improvement() in cityturn.c, in a manner
consistent with the renaming of upgrade_unit().
Description: Text document