Complete.Org: Mailing Lists: Archives: freeciv: June 2002:
[Freeciv] Re: i may be having a problem

[Freeciv] Re: i may be having a problem

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: <freeciv@xxxxxxxxxxx>
Subject: [Freeciv] Re: i may be having a problem
From: "P.G. Willemsen" <pgwillemsen@xxxxxxxxxx>
Date: Sat, 22 Jun 2002 13:01:08 +0200

> 2) because i wanted to begin against ai, i tried to type civserver into
> prompt.

You always need civserver, also when you play against humans. The only
exception is if you play against a civserver running on (the
freeciv Metaserver).

> 3)typed start client (remember, im a computer moron) no luck.  so, again
> using windows i clicked on the civclient icon.  tried typing, but received
> response.

You should double click on civclient or type civclient in the command
windows. Not the same command window, as civserver is running there and the
commands you type will be interpreted by civserver and not by the command
window itself.

> 4)opened another command prompt and switched directories...again, it
> accept any commands....however, a game screen popped up, as did a connect
> screen, which i clicked.  for some reason, i have problems connecting
> network connection, so i used the connection supplied by aol.

You should not need a network connection, nor a connection supplied by aol
(=internet connection?). Since you are playing against ai, the only thing
you need is one pc. You can remove all modems, lan cables etc. and still
play the game. You should connect to or localhost, and leave the
port setting to the default.

This should really work. The connection screen should disappear and the
civserver window should show a message that you connected. If this goes
wrong, you probably have not installed TCP/IP properly. Review your network

> 5)okay.  all looks good, except i cannot play.  i cannot access gov,
> or other sections of the game screen, and no new screens pop up to allow
> access to these other game screen sections.

OK. You just did not start the game. You are connected to the civserver
running on you pc, but that server is still waiting for others to join the
game. Switch to the civserver console window en type 'start'. You will be
asked to choose a nation and the game will begin!

> i have played with some of the civserver and civclient screens that pop
> occasionally, when typing start, it will seem to accept the command, but i
> get no further response.  othertimes i get a response like, not enough
> players, will not start.

It *may* be possible that you connected to another civserver on the internet
(you mentioned using your aol connection). So your local civserver has no
clients to start (perhaps only ais, so it will start with only ais), and
your civclient is waiting for the remote civserver to start. Make sure you
connect to (or localhost) and the civserver windows tells you that
you have been connected.

If it still does not work, tell us all civserver messages (in the civserver
console window).

kind regards,

Peter Willemsen

[Prev in Thread] Current Thread [Next in Thread]