Complete.Org: Mailing Lists: Archives: freeciv: April 2001:
[Freeciv] Re: Help With Installation Please

[Freeciv] Re: Help With Installation Please

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: freeciv@xxxxxxxxxxx
Subject: [Freeciv] Re: Help With Installation Please
From: John Kennedy <jfk@xxxxxxx>
Date: Fri, 20 Apr 2001 02:22:10 +0900

Fools rush in

You should check out fink. It's a program that allows you to download and compile tons of packages and does most of the work for you. Free civ isn't included unfortunately, but I've set up wmaker and gimp. Gimp is wonderful, it is like a free version of photoshop.

If you're unaware, you should also install xonx, it's great and allows you to go back and forth between xwindows and aqua. When in aqua, you have an X icon in the dock, clicking on it puts you back into your x desktop. In your x desktop command option a takes you back to aqua. Very small but nice program.
Check it out at

And check out fink at

Anyway, I included the above to let you know there is a ton of stuff people are doing now with osx.

I have gtk+ and imlib installed (I needed them for gimp), but they may be different versions than what freeciv is looking for. Though the config script seemed to think I had everything.

If I do get it running, I will pass along any tips.


First let me say you are a brave man to be trying this under osx.  :)

I'm on osx now as well, I've gotten Xwindows running so I might be able to give you some pointers in the right direction (although it hadn't yet occurred to me to try to compile freeciv on it). First, have you gotten the recent 10.0.1 update? That might help. Second, do you have development libraries for Xwindows installed? If you installed Xwindows from binary you may not have them. Do you have a window manager and/or GTK+ installed?

This may turn into an error in the compiler or something "deep" like that, so check out the darwin development lists and sites. See if any other *NIX programs have had this trouble compiling.

Let me know what find out so that when I get around to installing freeciv, I can follow your guidance!

William Mulvihill, Web Master
DxR Development Group, Inc.
150 E. Pleasant Hill Road
Carbondale, IL 62901
phone (618)453-4789
free  (800)453-8040
fax   (618)453-5309
On Thursday, April 19, 2001, at 11:32 AM, John Kennedy wrote:

Hello all,

I am trying to install freeciv. I am on a mac running osx, but I also have xwindows up and running under bsd. I ran the configure script which didn't complain about anything missing but when I run make I get the following output:

Making all in common
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../intl    -g -O2 -Wall -c city.c
city.c:97: bad macro argument list
city.c:97: bad macro argument list
city.c:97: bad macro argument list
city.c:97: bad macro argument list
city.c:97: bad macro argument list
city.c:97: bad macro argument list
city.c:97: bad macro argument list
cpp-precomp: warning: errors during smart preprocessing, retrying in basic mode
make[2]: *** [city.o] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2

Any ideas on how to get this up and running? Any help would be greatly appreciated. Thanks




[Prev in Thread] Current Thread [Next in Thread]
  • [Freeciv] Re: Help With Installation Please, John Kennedy <=