Complete.Org: Mailing Lists: Archives: freeciv-dev: August 2004:
[Freeciv-Dev] (PR#9799) PATCH: rewrited adjust_map()

[Freeciv-Dev] (PR#9799) PATCH: rewrited adjust_map()

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: mburda@xxxxxxxxx
Subject: [Freeciv-Dev] (PR#9799) PATCH: rewrited adjust_map()
From: "Mateusz Stefek" <mstefek@xxxxxxxxx>
Date: Tue, 31 Aug 2004 04:06:37 -0700
Reply-to: rt@xxxxxxxxxxx

<URL: >

> [mburda - Tue Aug 31 08:44:50 2004]:
> to be commited ;-)
> Marcelo
Please add some comment here:

+static const int maxval = 1000;
+static int seaval=0, mountainsval =0;

I'd like to see better name for f[] in adjust_hmap

f[i] = (count * maxval) / (map.xsize * map.ysize) 
I'm not sure if map.xsize * map.ysize is a real total number of tiles on
a map. Some topology expert should say something about it (That's not me).

Style fixes:

int count=0 
should be
int count = 0
should be 
INITIALIZE_ARRAY(f, maxval, 0);

I like this patch.
Jason had some objections so you have to wait for him.

[Prev in Thread] Current Thread [Next in Thread]