[Freeciv-Dev] Re: (PR#6947) [Bug] is_at_coast is misleading
[Top] [All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
<URL: http://rt.freeciv.org/Ticket/Display.html?id=6947 >
On Tue, 25 Nov 2003, Mike Kaufman wrote:
>
> <URL: http://rt.freeciv.org/Ticket/Display.html?id=6947 >
>
> On Tue, Nov 25, 2003 at 08:45:12AM -0800, Gregory Berkolaiko wrote:
> >
> > I don't see any uses of is_at_coast which rely on this behaviour (maybe
> > mapgen, it is dubious). I think is_ocean_near_tile should be renamed
> > is_at_coast and retired (I like the shorter name).
>
> have you checked the tilespec code? terrain overlap may need this.
> (could be a static function though)
It's only called from mapgen and AI (which thinks it's
is_ocean_near_tile):
ai/aisettler.c: if (do_overseas && is_at_coast(punit->x, punit->y)) {
ai/aisettler.c: if (do_overseas && !port && is_at_coast(pos.x, pos.y))
{
ai/aitools.c: if (is_at_coast(punit->x, punit->y)) {
ai/aitools.c: && (!is_at_coast(punit->x, punit->y)
ai/aitools.c: if (is_at_coast(punit->x, punit->y)) {
ai/aitools.c: if (!is_at_coast(dest_x, dest_y)
ai/aiunit.c: if (is_at_coast(leader->x, leader->y) && leader->fuel == 0)
{
common/map.c:bool is_at_coast(int x, int y)
server/mapgen.c: &&( !is_at_coast(x, y) || myrand(100) < coast
)) {
server/mapgen.c: &&( !is_at_coast(x, y) || myrand(100) < coast
)) {
|
|