Complete.Org: Mailing Lists: Archives: discussion: October 1998:
Re: [aclug-L] kernel updates

Re: [aclug-L] kernel updates

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: aclug-L@xxxxxxxxxxxx
Subject: Re: [aclug-L] kernel updates
From: Bob Deep <bobd@xxxxxxxxxxxx>
Date: Fri, 23 Oct 1998 10:11:46 -0500
Reply-to: aclug-L@xxxxxxxxxxxx

Todd_Lundstedt@xxxxxxxxxxxxxxx wrote:
> Have patience with me, I am very new at this....
> I have RH5.1.

Ahh, Red Hat 5.1..  Not their best effort at a release, but I run it and
I have a few answers for your problems.

> I download several of the update RPMs from the RH ftp site and, including
> kernel, glint, and a few others that RH Security suggests all RH users
> should install.  

This is a very good idea...  Gota keep up with all their fixes if

> The RPMs installed without error (except kernel-source...
> ran out of space).  

Larger /usr partition is in order, unless you don't mind using their
pre-compiled kernel (and I minded because it is too big an clunky for my
small box).

> When I tried to use glint, the file is not in the
> directory.  

Huh?  What file is not in what directory?  Now, if you are running the
glint from the distro, it has bugs (bad ones) and is barely functional
enough to come up...  I had to install the upgrade for glint by hand
before I could get it to install anything.  You just have to run "rpm"
by hand, but it is very easy (try "rpm --upgrade glint*.rpm" in the
directory with the rpm file you got from Red Hat.)

> After reboot, I can't mount the CDRom, (error indicates ISO9660
> not supported in kernel), 

Yea, Red Hat sorta messed up that a bit.  What happened is that they put
the ISO9660 file system driver in a module, but did not make it so the
module would be auto-loaded when you needed it.  Do two things, 1.  Run
"depmod --all" to set up your dependancies, 2. then make sure the
autoloader demon is runing (I forgot exactly how that is done as I'm
running kernel 2.1.122 which does its own module loading).

Worst case you just run monprobe on the ISO9660 module (Can someone
recall the module name?) then run your mount command.

> the Ethernet card did not initialize and few
> other errors.

Funny, if it is a ne2000 compatable, it should init without much
fanfair.  The driver found my moldy oldy somewhat ne2000 compatable ISA
cards on differant IO and Interrupts with no problem.  Now if you put
more than one card in the box, you have to let the driver know to look
for more.  Two possible answers come to mind here... 1. The card is not
configured (It does not answer to an IO/Interrupt so the driver does not
find it) or 2. the card is not really ne2000...  My cards configured by
setting jumpers, many must be configured with a setup disk that writes
the configuration to some eeprom, either way, make sure your card is set

> Since I can't get to the CD or Network, I am stuck with updating by floppy
> (never done that before), reinstalling (done that plenty, but don't want
> to), or finding some way to back out the kernel changes and continue on (if
> it ain't too hard).

Let's try to get the CD mounted before we resort to the floppy...

> Some of the other errors are
> modprob: can't locate module net-pf-4 (then -pf-5)

You can ignore these... Don't know exactly what they are, but they don't
seem to be a problem on my box.

> I am booting off of floppy, if that matters.  I can't figure out how to get
> Linux to recognize the Bios overlay for larg hard drives and still boot.
> Everytime I try to install and boot from hard drive, I get "LI" and that is
> it.  Booting from floppy works, but I would sure like to fix that.

Let me guess... Ezdrive?  Now, this is a somewhat complex issue. 
Ezdrive inserts its self on the master boot record of your drive, which
is exactly where Lilo tries to insert its self so unless you keep things
straight, lilo will overwrite your ezdrive master boot record or
vise-versa. Should lilo toast your Ezdrive and you try to access your
drive w/o Ezdrive very bad things happen.  I've lost my whole drive
twice because lilo overwrote Ezdrive (which is not in it's self
unrecoverable) and then I did something stupid trying to recover (like
trying to re-install Ezdrive.)  Follow this one simple rule...  ALWAYS
let Ezdrive load its self FIRST.  So if you need to bood from the
floppy, use the Ezdrive "boot from floppy" way and don't just boot
directly.  Don't worry, Linux will run fine with the Bios extension
loaded (even though it takes a bit of memory).  The Bios is largely
ignored by Linux anyway.

If Ezdrive is loaded first, it relocates the master boot record and
intercepts Bios calls to write new master boot record and partition
table entries so you write to the right places so everything is just
fine.  But if you, say boot directly from a floppy and Ezdrive does not
get loaded things can go south quick.

You can fix the "LI" problem with lilo by giving it the "linear" option
in your /etc/lilo.conf file.

You may have troubble with fdisk not reading the drive paramaters right,
but it will complain about that problem...  Diskdruid does NOT complain
and I'm not totally sure it is smart enough to figure out what's going
on..  So be careful.  Writing partition tables with the wrong drive
paramaters will cause much heart burn.  Please keep GOOD BACKUPS until
you have a stable system!

> On the space issue, how do I increase the space on a directory (is that
> correct term?) without destroying data in that directory (/usr for
> instance)?

It is not really possible to grow a partition (as far as I know).  (It
does not seem that difficult though...)  You have two choices.  1. 
Create a new partition that's bigger and copy the data from the old /usr
to the new... Change your fstab so the new is mounted as /usr and you
got more space. OR 2. Just make a new partition and mount it as a part
of the /usr partition (say as /usr/src/linux-2.0.34) which will move the
data in /usr/src/linux-2.0.34 off the /usr partition that's full...(Be
sure to move the data before you do the mount, or the data will stay on
your disk, but you won't be able to access it.)  Remember that using
Ezdrive and fdisk is not as easy as the books will indicate, so be
careful and if fdisk complains at all, GET OUT and don't save anything. 
Send me some mail if you have this problem and I'll tell you how to fix

I guess you could just use soft links and move the kernel sources to a
partition with more space... Let me know if you understand what the
three options are...

Good luck...  Perhaps we can get Red Hat to do some beta testing before
they start pressing thousands of CD's and save us all a lot of

-= bob =-
This is the Air Capitol Linux Users Group discussion list.  If you
want to unsubscribe, send the word "unsubscribe" to
aclug-L-request@xxxxxxxxxxxx.  If you want to post to the list, send your
message to aclug-L@xxxxxxxxxxxx.

[Prev in Thread] Current Thread [Next in Thread]