[Freeciv-Dev] bug report address in code
[Top] [All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
config.h currently includes a
#define MAILING_LIST "freeciv-dev@xxxxxxxxxxx"
which is used if the server or client is given --help on the
command line, and prints: (after actual help)
Report bugs to <freeciv-dev@xxxxxxxxxxx>.
This should probably now say <bugs@xxxxxxxxxxxxxxx> ?
Also, is there any reason the MAILING_LIST and SITE defines
should be in config.h (via configure.in) ? I would just have
then in shared.h, which is simpler and perhaps easier for
non-configure make methods.
(Also^2, I would prefer slightly more descriptive names
for these defines.)
The above changes are made in the attached patch. I guess also
the README and helptext about bug reports should be changed,
but I haven't done that yet.
Regards,
-- David
diff -u -r --exclude-from exclude_auto freeciv-cvs/acconfig.h fc-adv/acconfig.h
--- freeciv-cvs/acconfig.h Sun Jun 13 15:18:38 1999
+++ fc-adv/acconfig.h Thu Jun 17 21:45:13 1999
@@ -19,8 +19,6 @@
#undef IS_BETA_VERSION
#undef VERSION_STRING
#undef FREECIV_DATADIR
-#undef MAILING_LIST
-#undef SITE
#undef HAVE_LIBICE
#undef HAVE_LIBSM
#undef HAVE_LIBX11
diff -u -r --exclude-from exclude_auto freeciv-cvs/client/civclient.c
fc-adv/client/civclient.c
--- freeciv-cvs/client/civclient.c Thu Jun 17 21:36:44 1999
+++ fc-adv/client/civclient.c Thu Jun 17 21:45:13 1999
@@ -104,7 +104,7 @@
#endif
fprintf(stderr, " -version\tPrint the version number\n");
fprintf(stderr, " -tiles D\tLook in data subdirectory D for the tiles\n");
- fprintf(stderr, "Report bugs to <%s>.\n",MAILING_LIST);
+ fprintf(stderr, "Report bugs to <%s>.\n", BUG_EMAIL_ADDRESS);
exit(0);
}
diff -u -r --exclude-from exclude_auto freeciv-cvs/common/shared.h
fc-adv/common/shared.h
--- freeciv-cvs/common/shared.h Thu Jun 17 21:36:44 1999
+++ fc-adv/common/shared.h Thu Jun 17 21:45:13 1999
@@ -16,6 +16,9 @@
/* Note: the capability string is now in capstr.c --dwp */
/* Version stuff is now in version.h --dwp */
+#define BUG_EMAIL_ADDRESS "bugs@xxxxxxxxxxxxxxx"
+#define WEBSITE_URL "http://www.freeciv.org"
+
#define CITY_NAMES_FONT "10x20"
#define BROADCAST_EVENT -2
diff -u -r --exclude-from exclude_auto freeciv-cvs/config.h.in
fc-adv/config.h.in
--- freeciv-cvs/config.h.in Sun Jun 13 15:18:38 1999
+++ fc-adv/config.h.in Thu Jun 17 21:45:13 1999
@@ -34,8 +34,6 @@
#undef IS_BETA_VERSION
#undef VERSION_STRING
#undef FREECIV_DATADIR
-#undef MAILING_LIST
-#undef SITE
#undef HAVE_LIBICE
#undef HAVE_LIBSM
#undef HAVE_LIBX11
diff -u -r --exclude-from exclude_auto freeciv-cvs/configure.in
fc-adv/configure.in
--- freeciv-cvs/configure.in Sun Jun 13 15:18:40 1999
+++ fc-adv/configure.in Thu Jun 17 21:45:14 1999
@@ -10,8 +10,6 @@
AC_PREREQ(2.12)
PACKAGE=freeciv
-MAILING_LIST=freeciv-dev@xxxxxxxxxxx
-SITE=http://www.freeciv.org
dnl client/server should always have the same major and minor versions
dnl different patch versions are compatible
@@ -33,8 +31,6 @@
AC_DEFINE_UNQUOTED(PATCH_VERSION, $PATCH_VERSION)
AC_DEFINE_UNQUOTED(VERSION_STRING,
"${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}")
AC_DEFINE_UNQUOTED(IS_BETA_VERSION, $IS_BETA_VERSION)
-AC_DEFINE_UNQUOTED(MAILING_LIST, "${MAILING_LIST}")
-AC_DEFINE_UNQUOTED(SITE,"${SITE}")
dnl Initialize automake stuff
AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
diff -u -r --exclude-from exclude_auto freeciv-cvs/server/civserver.c
fc-adv/server/civserver.c
--- freeciv-cvs/server/civserver.c Thu Jun 17 21:34:03 1999
+++ fc-adv/server/civserver.c Thu Jun 17 21:45:15 1999
@@ -245,7 +245,8 @@
}
con_write(C_VERSION, "This is the server for %s", FREECIV_NAME_VERSION);
- con_write(C_COMMENT, "You can learn a lot about Freeciv at %s", SITE);
+ con_write(C_COMMENT, "You can learn a lot about Freeciv at %s",
+ WEBSITE_URL);
if(h) {
fprintf(stderr, " -f, --file F\t\tLoad saved game F\n");
@@ -263,7 +264,7 @@
fprintf(stderr, " -d, --debug N\t\tSet debug log level (0,1,2)\n");
#endif
fprintf(stderr, " -v, --version\t\tPrint the version number\n");
- fprintf(stderr, "Report bugs to <%s>.\n",MAILING_LIST);
+ fprintf(stderr, "Report bugs to <%s>.\n", BUG_EMAIL_ADDRESS);
exit(0);
}
@@ -274,7 +275,7 @@
#if IS_BETA_VERSION
con_write(C_COMMENT, "Freeciv 1.8 will be released "
- "third week of March at %s", SITE);
+ "third week of March at %s", WEBSITE_URL);
#endif
con_flush();
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- [Freeciv-Dev] bug report address in code,
David Pfitzner <=
|
|