Complete.Org: Mailing Lists: Archives: freeciv-ai: December 2004:
[freeciv-ai] Re: [Freeciv-Dev] (PR#11396) Treaty doesn't always respect

[freeciv-ai] Re: [Freeciv-Dev] (PR#11396) Treaty doesn't always respect

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
Subject: [freeciv-ai] Re: [Freeciv-Dev] (PR#11396) Treaty doesn't always respect money transfer
From: "(Nathanael Nerode)" <neroden@xxxxxxxxxxx>
Date: Fri, 10 Dec 2004 09:44:31 -0800
Reply-to: bugs@xxxxxxxxxxx

<URL: >

Per I. Mathisen wrote:
> <URL: >
> On Tue, 7 Dec 2004, (Nathanael Nerode) wrote:
>>In the GTK client, I can set various amounts of money
>>to be transferred as part of a deal, but
>>* the AIs apparently don't notice it, because they never change opinion
>>* the money usually doesn't get transferred.(I haven't figured out when,
>>exactly, it does.)
>>(This is in the fourth beta for 2.0.0)
> Works for me, gtk2 client, cvs head.

Well, I am using the gtk2 client (under KDE).

I tried beta5, and am still getting the same problem.

I tried making a treaty with the Zulus and asking them to give me 75 
gold for (for instance) my seamap.  They agreed, but no gold was 
transferred (my gold total did not change)....

Aha!  I figured it out, through sheer luck.

After I change the gold total, I have to hit "return" in order for it to 
be entered as a clause.  Why?!?  This is particularly nonobvious when 
using the arrow buttons in the combo box, with the mouse.

If this is a GTK2 problem and can't be fixed, it should be noted in the 
FAQ, release notes, or something.

Attachment: nomoney.sav.gz
Description: application/gzip

[Prev in Thread] Current Thread [Next in Thread]