Complete.Org: Mailing Lists: Archives: discussion: November 1999:
[aclug-L] NFS Install problem

[aclug-L] NFS Install problem

[Top] [All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index] [Thread Index]
To: <aclug-l@xxxxxxxxxxxx>
Subject: [aclug-L] NFS Install problem
From: "Veracom" <ncozzens@xxxxxxxxxxx>
Date: Wed, 24 Nov 1999 08:11:41 +0300
Reply-to: aclug-L@xxxxxxxxxxxx

Howdy fellow ACLUGers,

Greetings from the arid land of Ahab, the dehydrated Arab.

Linux is finally starting to make more sense to me.  I'm making progress
(despite missing the past two meetings).  I think it was the NetWorkshop
that got the ball rolling.  This mailing list is also a tremendous help.
Thankyou to those who spend time reading and answering the mail of those who
understand less than you.

I have an NFS install problem.

I'm trying to install RedHat 6.0 on a laptop that makes you choose between
floppy and cdrom.  Therefore, I'm using a crossover 10BaseT cable for my
attempted NFS install.  I've got NFS setup on the server
(, pancf25.psab), sharing to the client machine (
,gateway.psab).  I setup all the NFS server stuff during the server's
so I'm pretty sure all the necessary components are there.

Is it OK to just use pancf25.psab, or do I need to throw in a .com?  What
makes a FQDN, and when is it important?

I used linuxconf to setup all of my server's network related files.  Here
they are.


/etc/hosts:       localhost       localhost.localdomain    pancf25.psab    pancf25    gateway.psab    gateway

I boot up the NFS server, mount the CDROM, boot the client
with the bootnet.img floppy, feed it the PCMCIA support disk, and enter all
the following TCP/IP info on the client machine:

Configuration of TCP/IP (for this machine):
IP address:           
Default gateway (IP): 
Primary nameserver:   

Configure Network:
Domain name:                    psab
Host name:                      pancf25.psab
Secondry nameserver (IP):
Tertiary nameserver (IP):

NFS Setup:
NFS server name:      
Red Hat directory:              /mnt/cdrom

and then get the baad message:(

It says:
NFS mount failed.  Permissions denied.

I can't figure out how to give away any more permissions.


In the process of writing this letter, I tried the whole thing again.  The
only thing I changed was the server's /etc/networks.  With the help of
linuxconf, I changed it to the following:

pancf25.psab    pancf25

Now I don't even get the baad message.  I just get the little cursor that
sits there and blinks at me indefinitely.


I just tried it again, this time I changed an entry on the client.  "Host
name:" line in the Configure Network screen.  Instead of the server
(pancf25.psab), I put the client (gateway.psab).  This time the CDROM on the
server spun up in response to the client's request, but I still got the
indefinite blinking cursor.

It seems like the networking side of things is working properly.  One time I
tried all this when the CDROM wasn't installed in the server.  The client
told me it didn't look like /mnt/cdrom contained the RedHat installation
tree.  Evidently it can see it.

Any ideas?

Sorry this was so long.
I appreciate your patience and help.

[Prev in Thread] Current Thread [Next in Thread]